PAT Advanced—1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains Knumbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

参考思路:
  动态规划,根据前面子序列保存的信息,求后面的最大值。比如只要一段序列的和<0,就应该摒弃这段数列,新的序列从下一位开始继续,因为负数不可能做首项。在这其中,只要出现了较大的数列和,就保存起来。后面的与这个比较即可。关键地方在于怎么保存最大子序列的索引

注意:

  1. 题目输出格式中明确说了,当全部为负数的时候,输出该序列首尾项。所以在这里我们要根据是否有0项,来判断该怎么输出。可以令首项为-1,这样就可以根据其是否会变成0,来判断是否应该改变索引。
  2. 题目中还表明可能存在相同大小的最大子序列,此时要输出其索引值最小的,所以我们直接从左向右移动,用<号判断,就是最小的索引。

代码:(C++)

#include<iostream>
#include<vector>

using namespace std;

int main()
{
	int n;
	cin>>n;
	vector<int> sum(n+1,0);
	for(int i=1; i<=n; i++)
		cin>>sum[i];
	
	int left = 1;
	int right = n;  //left用来记录最大子序列的首尾索引
	int current = 1;  //此为当前访问的子数列的其实位置
	int temp = 0;  //临时最大值
	int max_num = -1;  //最大值
	
	for(int i=1; i<=n; i++)
	{
		temp += sum[i];
		if(temp < 0)  //temp<0了,说明当前的子数列不行了,得重新开始索引
		{
			temp = 0;
			current = i+1;  //当前子数列索引到下一个位置
		}
		else if(max_num < temp)  //这两个操if作只会执行其中的一个,所以不用再考虑temp<0时,max_num需不需要改变
		{
			max_num = temp;
			left = current;  //更新最大子数列,左边为当前数列索引
			right = i;
		}
	}
	if(max_num < 0)
		max_num = 0;  //当它为-1的时候,说明其都是负数,给它变成0
	//这里的输出,如果输入全为负数,
	printf("%d %d %d", max_num, sum[left], sum[right]);

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值