PAT Advanced 1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be ( yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

选择三场球赛中赔率最大的三个选项并计算收益,保留两位小数。
#include <bits/stdc++.h>

using namespace std;

int main()
{
    float ans=1;
    float odds[3],odds2[3];
    char choice[3];
    for(int i=0;i<3;i++)
    {
        cin>>odds[0]>>odds[1]>>odds[2];
        odds2[0]=odds[0];
        odds2[1]=odds[1];
        odds2[2]=odds[2];
        sort(odds2,odds2+3);

        if(odds2[2]==odds[0])
        {
            choice[i]='W';
        }else if(odds2[2]==odds[1])
        {
            choice[i]='T';
        }else{
            choice[i]='L';
        }
        ans*=odds2[2];
    }
    ans*=0.65;
    ans-=1;
    ans*=2;
    cout<<choice[0]<<' '<<choice[1]<<' '<<choice[2]<<' ';
    cout<<fixed<<setprecision(2)<<ans<<endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/zest3k/p/11455908.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值