1879_Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.


Input

Each line of input contains an integer n < 3000 followed by n integers representing the sequence.


Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".


Sample Input

4 1 4 2 3
5 1 4 2 -1 6


Sample Output

Jolly
Not jolly


Source: University of Waterloo Local Contest 2000.09.30

×××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××

//给出1~n之间n个数。如果相邻两数差值1~n-1都出现过则为jolly jumper.如果只有一个数则也为jolly jumper
//刚开始题意理解成n个数里面是否将1~n内的数全部包含
#include<iostream>
using namespace std;
int main()
{
int test[3000];
int size,num,num1,num2;
bool flag;
int i;
while(cin>>size)
{   
for(i=1;i!=size;i++)
test[i]=0;
flag=true;
i=size;
while(i--)
{

cin>>num1;
if(i==size-1)//第一次不减
{
                num2=num1;
continue;
}
num=num1-num2;
num2=num1;
if(num<0)//求绝对值
num=-num;
if(num>0&&num<size)//判断是否在1~n-1之内
  test[num]=1;
}
for(i=1;i!=size;i++)
if(test[i]==0)//判断是否将1~n内的数全部包含
{
flag=false;
break;
}
if(flag)
cout<<"Jolly"<<endl;
else
cout<<"Not jolly"<<endl;
}
return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值