Jolly Jumpers,zcmu 1857

1857: Problem C: Jolly Jumpers
时间限制: 1 Sec  内存限制: 128 MB
提交: 146  解决: 47
[提交][状态][讨论版]
题目描述
Problem C: Jolly Jumpers
A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,


1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.


Each line of input contains an integer n < 3000 followed by n integers representing the sequence. For each line of input, generate a line of output saying "Jolly" or "Not jolly".


输入
输出
样例输入
4 1 4 2 3
5 1 4 2 -1 6
样例输出
Jolly
Not jolly
提示

来源


题目的意思是序列的相邻两项的差为1到n-1则为Jolly。

心得:用数组存储差值判断是否存在符合的值,若有值不存在则不符合条件。

#include<bits/stdc++.h>
using namespace std;
int a[3003],b[3003];
int main(void)
{
	int n;
	while(~scanf("%d",&n))
	{
		int i,min,r;
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<n;i++) scanf("%d",&a[i]);
		for(i=1;i<n;i++)
		{
			int tp=abs(a[i]-a[i-1]);
			b[tp]=1;
		}
		int fg=1;
		for(i=1;i<n;i++)
			if(b[i]==0)
			{
				fg=0;break;
			}
		if(fg) printf("Jolly\n");
		else printf("Not jolly\n"); 
	}
	return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值