2345_Gold Coins(输入分多个块,每个块中有多行,每个输入块之间有空格,但最后没有空格)

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receiveN+1 gold coins on each of the nextN+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

Each input block contains at least one, but no more than 21 lines. Each line of the input (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

Sample Input

1

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98


Source: Rocky Mountain 2004

//第一天给一块,然后两天各给两块,然后三天各给三块,输入天数,求块数
//输入输出很讲究,输入分多个块,每个块中有多行,每个输入块之间有空格,但最后没有空格。
#include<iostream>
using namespace std;
int main()
{
int day,coin;
int i,j,dd;
int num;//块号
cin>>num;
while(num--)
{
   while(cin>>day&&day)
{
if(day==0)
break;
dd=i=coin=0;
while(dd<day)
{   
i++;
dd+=i; 
}
dd-=i;
for(j=1;j!=i;j++)
coin+=j*j;
coin+=(day-dd)*i;
cout<<day<<" "<<coin<<endl;
}
if(num!=0)//每个输入块之间有空格,但最后没有空格
 cout<<endl;
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
是的,我们可以使用一个简单的迭代算法来计算所有组合方式。这种算法的思想是: - 对于每一种货币面额,计算它可以组成的所有金额的组合方式。 - 对于每个金额,它的组合方式数等于所有货币面额的组合方式数之和。 以下是Python程序实现: ```python def count_ways(amount, coins): n = len(coins) ways = [0] * (amount + 1) ways[0] = 1 for i in range(n): for j in range(coins[i], amount + 1): ways[j] += ways[j - coins[i]] return ways[amount] amount = int(input("请输入金额:")) coins = [1, 2, 5, 10] # 可以根据需要修改货币面额 ways = count_ways(amount, coins) print("总共有 %d 种组合方式" % ways) ``` 在这个程序,我们首先创建一个长度为 `amount + 1` 的数组 `ways`,其 `ways[i]` 表示组成i元的组合方式数。然后,我们将 `ways[0]` 初始化为1,因为组成0元的方式只有一种(即不选择任何货币)。 接下来,我们遍历所有的货币面额和金额,并使用以下递推公式计算 `ways[j]`: - 如果当前的货币面额 `coins[i]` 小于等于j,那么 `ways[j]` 可以由两部组成:一部是使用前i-1种货币组成j元的组合方式数 `ways[j]`,另一部是使用第i种货币组成剩余的j-coins[i]元的组合方式数 `ways[j-coins[i]]`。因此,`ways[j]` 可以等于 `ways[j] + ways[j - coins[i]]`。 - 如果当前的货币面额 `coins[i]` 大于j,那么使用第i种货币无法组成j元,因此 `ways[j]` 不变。 最后,我们返回 `ways[amount]`,即用所有货币组成目标金额的组合方式数。 这种迭代算法的时间复杂度为 O(nm),其n是货币种类数,m是需要组合的金额。虽然时间复杂度比动态规划算法低,但它只能处理较小的金额和货币种类。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值