POJ 3714 Raid(变种最近点对问题:分治+剪枝)

Raid
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 11728 Accepted: 3494

Description

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

Sample Output

1.414
0.000
/*
分治剪枝,直接把代理和车站放在同一数组中,只是在初始化时给予不同的flag
直接套用HDU1007的模板即可,在判断最小距离时先判断flag是否不等即可
*/
#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
const double eps = 1e-8;
const double PI = acos(-1.0);
#define INF 0x3f3f3f3f
#define maxn 1000100


int sgn(double x)
{
	if (fabs(x) < eps)return 0;
	if (x < 0)return -1;
	else return 1;
}
struct Point
{
	double x, y;
	int flag;
	Point() {}
	Point(double _x, double _y)
	{
		x = _x; y = _y;
	}
	Point operator -(const Point &b)const
	{
		return Point(x - b.x, y - b.y);
	}
	//叉积
	double operator ^(const Point &b)const
	{
		return x*b.y - y*b.x;
	}
	//点积
	double operator *(const Point &b)const
	{
		return x*b.x + y*b.y;
	}
	//绕原点旋转角度B(弧度值),后x,y的变化
	void transXY(double B)
	{
		double tx = x, ty = y;
		x = tx*cos(B) - ty*sin(B);
		y = tx*sin(B) + ty*cos(B);
	}
}p[maxn], t[maxn];

double dist(Point a, Point b)
{
	if (a.flag != b.flag)
		return sqrt((a - b)*(a - b));
	else
		return INF;
}

bool cmpx(const Point& a, const Point& b)
{
	return a.x<b.x || (a.x == b.x && a.y<b.y);
}
bool cmpy(const Point& a, const Point& b)
{
	return a.y<b.y || (a.y == b.y && a.x<b.x);
}

double closest(int left, int right)
{
	double d = INF;
	if (left == right)
		return d;
	if (left + 1 == right)
		return dist(p[left], p[right]);
	int mid = (left + right) / 2;
	double d1 = closest(left, mid);
	double d2 = closest(mid + 1, right);
	d = min(d1, d2);
	int k = 0;
	for (int i = left; i <= right; i++)
		if (fabs(p[i].x - p[mid].x) <= d)
			t[k++] = p[i];
	sort(t, t + k, cmpy);
	for (int i = 0; i < k; i++)
		for (int j = i + 1; j < k&&t[j].y - t[i].y < d; j++)
			d = min(d, dist(t[i], t[j]));
	return d;
}

int main()
{
	int n,T;
	scanf("%d", &T);
	while ( T--)
	{
		scanf("%d", &n);
		double x, y;
		for (int i = 0; i<n; i++)
		{
			scanf("%lf%lf", &x, &y);
			p[i] = Point(x, y);
			p[i].flag = 0;
		}
		for (int i = n; i<2*n; i++)
		{
			scanf("%lf%lf", &x, &y);
			p[i] = Point(x, y);
			p[i].flag = 1;
		}
		sort(p, p + 2*n, cmpx);
		printf("%.3f\n", closest(0, 2*n - 1));
	}

	return 0;
}


                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的纺织品企业财务管理系统,源码+数据库+毕业论文+视频演示 在如今社会上,关于信息上面的处理,没有任何一个企业或者个人会忽视,如何让信息急速传递,并且归档储存查询,采用之前的纸张记录模式已经不符合当前使用要求了。所以,对纺织品企业财务信息管理的提升,也为了对纺织品企业财务信息进行更好的维护,纺织品企业财务管理系统的出现就变得水到渠成不可缺少。通过对纺织品企业财务管理系统的开发,不仅仅可以学以致用,让学到的知识变成成果出现,也强化了知识记忆,扩大了知识储备,是提升自我的一种很好的方法。通过具体的开发,对整个软件开发的过程熟练掌握,不论是前期的设计,还是后续的编码测试,都有了很深刻的认知。 纺织品企业财务管理系统通过MySQL数据库与Spring Boot框架进行开发,纺织品企业财务管理系统能够实现对财务人员,员工,收费信息,支出信息,薪资信息,留言信息,报销信息等信息的管理。 通过纺织品企业财务管理系统对相关信息的处理,让信息处理变的更加的系统,更加的规范,这是一个必然的结果。已经处理好的信息,不管是用来查找,还是分析,在效率上都会成倍的提高,让计算机变得更加符合生产需要,变成人们不可缺少的一种信息处理工具,实现了绿色办公,节省社会资源,为环境保护也做了力所能及的贡献。 关键字:纺织品企业财务管理系统,薪资信息,报销信息;SpringBoot
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值