sdutacm-Power Strings

Power Strings

Time Limit: 1000MS Memory Limit: 65536KB

SubmitStatistic

ProblemDescription

Given two strings a and b we define a*b to be theirconcatenation. For example, if a = "abc" and b = "def" thena*b = "abcdef". If we think of concatenation as multiplication,exponentiation by a non-negative integer is defined in the normal way: a^0 ="" (the empty string) and a^(n+1) = a*(a^n).

Input

 Each test case is a line of input representing s, a string ofprintable characters. The length of s will be at least 1 and will not exceed 1 millioncharacters. A line containing a period follows the last test case.

 

Output

 For each s you should print the largest n such that s = a^n forsome string a.

 

ExampleInput
abcd
aaaa
ababab
.
ExampleOutput
1
4
3
Hint

 This problem has huge input, use scanf instead of cin to avoidtime limit exceed.

 

Author

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 1000005
int main()
{
  int num[N];
  char s[N];
  int n;
  while(scanf("%s",s),s[0]!='.')// 逗号表达式代替 if break
  {
     int j = -1;//j 表示前缀,i 表示后缀
     num[0] = -1;
     n = strlen(s);
     for(int i=0;i<n;)
     {
        if(j == -1||s[i] == s[j])num[++i] = ++j;
        else j = num[j];
     }
     if(n%(n-num[n])==0)  //解决特例 aabaabaa abcabcabc(符合条件)
     printf("%d\n",n/(n-num[n]));
     else puts("1");

  }
  return 0;
}


/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 64ms
Take Memory: 940KB
Submit time: 2017-02-08 20:21:20
****************************************************/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值