2017Beijing icpc E Cats and Fish HihoCoder - 1631

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input
There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn, ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output
For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input
2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1
Sample Output
1 0
0 1
0 3

code:

/*
    签到题,有m条鱼,n只猫,问x时间还剩下多少条完整的鱼和
    没吃完的鱼,n只猫每只猫需要花费a[i]时间吃鱼,多条猫吃鱼时,
    花费时间短的猫优先吃鱼
    思路:模拟时间,每只猫吃鱼的时间都在1,a[i]+1,a[i]*2+1
    先统计吃了的鱼,当鱼吃光时,再减去已经吃光的
    这样如果时间i%a[i]==1或a[i]==1则正好可以吃鱼(当鱼数目还够的情况下)
    如果i%a[i]==0则正好把鱼吃光
*/
#include<bits/stdc++.h>
using namespace std;
int a[100010],eat[100010];
int main()
{
    int m,n,x;
     while(~scanf("%d%d%d",&m,&n,&x))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
            sort(a+1,a+1+n);
            int tot = 0,B =0 ;
            for(int i=1;i<=x;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(tot<m&&(i%a[j]==1||a[j]==1))
                    {
                        tot++,B++,eat[j] = 1;
                    }
                    if(eat[j]&&i%a[j]==0)
                    {
                        B--;
                        eat[j] = 0;//用于减除tot>=m的情况
                    }
                }
            }
            printf("%d %d\n",m-tot,B);
    }
    return 0;
}

code2:

/*
    签到题,有m条鱼,n只猫,问x时间还剩下多少条完整的鱼和
    没吃完的鱼,n只猫每只猫需要花费a[i]时间吃鱼,多条猫吃鱼时,
    花费时间短的猫优先吃鱼
    思路:模拟时间,每只猫吃鱼的时间都在1,a[i]+1,a[i]*2+1
    先统计吃了的鱼,当鱼吃光时,再减去已经吃光的
    这样如果时间i%a[i]==1或a[i]==1则正好可以吃鱼(当鱼数目还够的情况下)
    如果i%a[i]==0则正好把鱼吃光
*/
#include<bits/stdc++.h>
using namespace std;
int a[100010],eat[100010];
int main()
{
    int m,n,x;
     while(~scanf("%d%d%d",&m,&n,&x))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
            sort(a+1,a+1+n);
            int tot = 0,B =0 ;
            for(int i=1;i<=x;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(tot<m&&(i%a[j]==1||a[j]==1))
                    {
                        tot++,B++,eat[j] = 1;
                    }
                    if(i%a[j]==0)
                    {
                        B--;
                    }
                        if(tot>=m)break;
                }
                if(tot>=m)break;
            }
            printf("%d %d\n",m-tot,B);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值