hdu-1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34146    Accepted Submission(s): 15112


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

# include<stdio.h>
# include<string.h>
# include<algorithm>
using namespace std;
int used[22];
int a[20];
bool pr[25];

void prime()
{
	memset(pr,1,sizeof(pr));
	int i,j;
	for(j = 2; j <= 20; j++)
	 for(i = 2; i <= 20; i++)
	   pr[j*i] = 0;
}

void dfs(int num, int n)
{
	int i;
  	if(num >= n && pr[a[n] + 1])
  	{
  		for(i = 1; i < n ; i++)
  		  printf("%d ",a[i]);
  		printf("%d\n",a[i]);
  		return ;
  	}
  	for(i = 2; i <= n ; i++)
  	{
  		if(!used[i] && pr[a[num] + i])
  		{
  			a[num + 1] =i;
  			used[i] = 1;
  			dfs(num + 1 ,n);
  			used[i] = 0;
  		}
  	}
  	
}

int main()
{
	int n;
	prime();
	a[1] =1 ;
	int t = 1;
	while(scanf("%d",&n) != EOF)
	{
		printf("Case %d:\n", t++);
		if((n&1) == 0)
		{
			memset(used,0,sizeof(used));
			dfs(1, n);
		}
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值