HDU 6075 Questionnaire

Questionnaire


Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.



Picture from Wikimedia Commons


Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0k<m) , and regard those people whose number is exactly k modulo m as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k .
 

Input
The first line of the input contains an integer T(1T15) , denoting the number of test cases.

In each test case, there is an integer n(3n100000) in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct integers a1,a2,...,an(1ai109) , denoting the number that each person chosen.
 

Output
For each test case, print a single line containing two integers m and k , if there are multiple solutions, print any of them.
 

Sample Input
  
  
1 6 23 3 18 8 13 9
 

Sample Output
  
  
5 3
 

这道题表面很有迷惑性,但其实很水很水。给你六个数字,让你找到一个数字m,并将六个数字对m取模后出现次数最多的值视为k。 输出这样的一组m,k。
刚开始的时候有点懵比,毕竟英语渣,是队友给我说的题意。后来队友想到既然可以取任意值,那直接对2取余就好了,相当于判断给定数字的奇偶性。记一下数字,输出数量多的就好了。


AC代码:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
long long int a;
int main()
{
    int T,n;
    int res=0;
    cin>>T;
    while(T--)
    {
        cin>>n;
        res=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a);
            if(a&1)
                res++;
        }
        if(res>=n-res)
            cout<<2<<" "<<1<<endl;
        else
            cout<<2<<" "<<0<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值