HDU 6075 Questionnaire - 思维题-2017多校联盟4 第9题

Questionnaire

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Special Judge


Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.



Picture from Wikimedia Commons


Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0k<m) , and regard those people whose number is exactly k modulo m as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k .
 

Input
The first line of the input contains an integer T(1T15) , denoting the number of test cases.

In each test case, there is an integer n(3n100000) in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct integers a1,a2,...,an(1ai109) , denoting the number that each person chosen.
 

Output
For each test case, print a single line containing two integers m and k , if there are multiple solutions, print any of them.
 

Sample Input
  
  
1 6 23 3 18 8 13 9
 

Sample Output
  
  
5 3


题意:

n个人分别给出n个数a1,a2,...,an(1ai109),让你找出m和k使得符合 ai %m = k的ai的个数多于不符合此条件的个数


解题思路

完全是脑筋急转弯啊。直接令m = 2,余数要么是1要么是0 ,如果奇数多就让k = 1 如果偶数多就让k=0,奇数偶数相等则随便



代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 100000+10;
int a[maxn];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        int odd = 0;
        int even = 0;
        scanf("%d",&n);
        for(int i = 0;i<n;++i){
            scanf("%d",&a[i]);
            if(a[i]%2) odd++;
            else even++;
        }
        if(even>=odd) printf("2 0\n");
        else printf("2 1\n");
    }


    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值