POJ 1002 487-3279

487-3279
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 297696 Accepted: 53244

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3


这道题犯了很多智障错误,显示刚开始没有重复的情况没有输出。然后又是改动代码时候有个地方没改,就一直卡,改的过程中还发现自己最后system没注释。

这道题思路就是把每个字符串变成一个int数字,然后用map记录出现次数。因为map自动具有排序的效果,直接从前到后遍历,输出次数大于1的电话号码。因为是以数字形式储存的,所以输出是要记得在空的地方补上零。

代码写的还是有些冗长了,虽然很多都是直接复制粘贴的。


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
using namespace std;
map<int, int>mp;
map<int, int>::iterator it;
int main()
{
	int n;
	char a[111];
	cin >> n;
	while (n--)
	{
		scanf("%s", &a);
		int res = 0;
		for (int i = 0; a[i]; i++)
		{
			if (a[i] == '-')
				continue;
			if (a[i] <= '9'&&a[i] >= '0')
				res = res * 10 + (a[i] - '0');
			if (a[i] == 'A' || a[i] == 'B' || a[i] == 'C')
				res = res * 10 + 2;
			if (a[i] == 'D' || a[i] == 'E' || a[i] == 'F')
				res = res * 10 + 3;
			if (a[i] == 'I' || a[i] == 'H' || a[i] == 'G')
				res = res * 10 + 4;
			if (a[i] == 'J' || a[i] == 'K' || a[i] == 'L')
				res = res * 10 + 5;
			if (a[i] == 'O' || a[i] == 'N' || a[i] == 'M')
				res = res * 10 + 6;
			if (a[i] == 'P' || a[i] == 'R' || a[i] == 'S')
				res = res * 10 + 7;
			if (a[i] == 'V' || a[i] == 'U' || a[i] == 'T')
				res = res * 10 + 8;
			if (a[i] == 'W' || a[i] == 'X' || a[i] == 'Y')
				res = res * 10 + 9;
			//cout << res << endl;
		}
		mp[res]++;
	}
	bool flag = 0;
	for (it = mp.begin(); it != mp.end(); it++)
	{
		if (it->second > 1)
		{
			flag = 1;
			int res1 = it->first / 10000;
			int res2 = it->first % 10000;
			printf("%03d-%04d ", res1, res2);
			cout << it->second << endl;
		}
	}
	if (!flag)
		cout << "No duplicates." << endl;
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值