POJ 1753 Flip Game

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48180 Accepted: 20532

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
 
这道题告诉我,我真的是连DFS都不会。
题意就是给你一个4*4的棋盘,w代表白色,b代表黑色。改变其中一个棋子的颜色,会使它相邻的四个棋子都变色。问最少经过几次变换能使棋盘全黑或全白,如果不能输出Impossible。
直接DFS每个棋子变色或者不变色的情况。
 
 
 
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int inf = 0x3f3f3f3f;
int res = inf;
int mp[5][5];
bool check()
{
	int cmp = mp[0][0];
	for (int i = 0; i < 4; i++)
		for (int j = 0; j < 4;j++)
			if (cmp != mp[i][j])
				return 0;
	return 1;
}
void change(int x, int y)
{
	mp[x][y] = !mp[x][y];
	if (x + 1<4)
		mp[x + 1][y] = !mp[x + 1][y];
	if (x - 1 >= 0)
		mp[x - 1][y] = !mp[x - 1][y];
	if (y + 1<4)
		mp[x][y + 1] = !mp[x][y + 1];
	if (y - 1 >= 0)
		mp[x][y - 1] = !mp[x][y - 1];
}
void dfs(int x, int y, int t)
{
	if (check())
	{
		res = min(res, t);
		return;
	}
	if (x == 4 || y == 4)
		return;
	int xx = x + (y + 1) / 4;
	int yy = (y + 1) % 4;

	change(x, y);
	dfs(xx, yy, t + 1);
	change(x, y);
	dfs(xx, yy, t);
}
int main()
{
	char s[5];
	for (int i = 0; i < 4; i++)
	{
		cin >> s;
		for (int j = 0; j < 4; j++)
		{
			if (s[j] == 'w')
				mp[i][j] = 0;
			else
				mp[i][j] = 1;
		}
	}
	dfs(0, 0, 0);
	if (res == inf)
		cout << "Impossible" << endl;
	else
		cout << res << endl;
	//system("pause");
	return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值