PAT_1023: Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
备注:简单题。在判断两个排列是否相同时卡了一下,后来用哈希搞定。
#include<stdio.h>
#include<string.h>

bool CheckPermutation(char s[],char t[])
{
	int digitMap1[10] = {0};
	int digitMap2[10] = {0};
	for(int i = 0; i < strlen(s); i++)
	{
		if(digitMap1[s[i]-'0']==0)
			digitMap1[s[i]-'0']=1;
	}
	for(int i = 0; i < strlen(t); i++)
	{
		if(digitMap2[t[i]-'0']==0)
			digitMap2[t[i]-'0']=1;
	}
	for(int i=0,j=0;i<10 && j<10;i++,j++)
	{
		if(digitMap1[i]!=digitMap2[j])
			return false;
	}
	return true;
}

void reverse(char s[])
{
	for(int i=0,j=strlen(s)-1;i<=j;i++,j--)
	{
		char c = s[i];
		s[i] = s[j];
		s[j] = c;
	}
}

int main()
{
	char num[30], res[30];
	int jinwei = 0, j = 0;
	scanf("%s",num);

	// compute the doubled number, store the result in res[] with revered order
	for(int i=strlen(num)-1;i>=0;i--)
	{
		int t = (num[i]-'0')*2+jinwei;

		if(t>=10)
		{
			jinwei = 1;
			res[j++] = t-10+'0';
		}
		else
		{
			jinwei = 0;
			res[j++] = t+'0';
		}
		if(i==0 && jinwei == 1)
			res[j++] = jinwei+'0';
	}
	res[j] = '\0';
	reverse(res);
	if(CheckPermutation(num,res))
		printf("Yes\n");
	else
		printf("No\n");
	printf("%s\n",res);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值