NYOJ-5 Binary String Matching

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
//虽然是英文,但从输入输出可以看出这是一道一个字符串在另一个字符串中出现的次数.
#include <stdio.h>
#include <string.h>
int main()
{
	int i,j,n,al,bl,s,f;
	char a[11],b[1000];
	while(scanf("%d",&n)!=EOF)
	{
		while(n--)
		{
			s=0;
			scanf("%s%s",a,b);
			al=strlen(a);
			bl=strlen(b);
			for(i=0;i<bl;i++)
			{
				if(b[i]==a[0])
				{
					f=1;
					for(j=1;j<al;j++)
					{
						if(b[i+j]!=a[j])
							f=0;
					}
					if(f) s++;
				}
			}
			printf("%d\n",s);		
		}
	}	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值