Unix ls

Unix ls

Description

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.


Input

The input will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 <= N <= 100). There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set { ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input.


Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.


Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben


Sample Output

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter

大意:

给出一个数字N,接下来N行给出N个文件名,按照ASCII码顺序,将N个文件名输出;

输出时将输出数据分为行和列,每一个测试集除最后一列外,前面的所有列宽度为最大文件名长度+2;

同是除最后一列外,若文件名长度 < 最大文件名长度+2,则补上空格;

要点:

若是列和行计算错误可能会导致浮点误差;

列的计算方式为l = (60 - max) / (max + 2) + 1;

行的计算方式为r = num / l,如果num % l != 0,r++;

注意最后一行的最后一列如上面测试3的Peter,Peter之后应该是不在输出空格的,直接输出结束;

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int cmp(const void *a, const void *b){
	return strcmp((char *)a, (char *)b);
}

int main(){
	int num;
	char str[105][65];
	while (scanf("%d", &num) != EOF){
		getchar();
		int count = 0;
		int max = 0;
		int n = num;
		while (n--){
			scanf("%s", str[count++]);
			if (max < strlen(str[count - 1]))
				max = strlen(str[count - 1]);
		}
		qsort(str, count,sizeof(str[0]), cmp);
		for (int i = 0; i < 60; i++)
			printf("-");
		printf("\n");
		int l = (60 - max) / (max + 2) + 1;
		int r = num / l;
		if (num % l != 0)
			r++;
		for (int i = 0; i < r; i++){
			for (int j = 0, p = i; j < l; j++){
				printf("%s", str[p]);
				p += r;
				if (p >= num)
					break;
				for (int k = 0; k < max + 2 - strlen(str[p - r]); k++)
					printf(" ");
				
			}
			printf("\n");
		}
	}

}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值