Ignatius and the Princess III

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23497    Accepted Submission(s): 16368


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627

    思路:

   dp方程,怎么推?怎么表示状态?

   根据题目解释样例:可以发现递减的将整数拆分,避免了重复性.

   那么,我们用f(i,j)表示将要拆分的数i拆成不大于j的累加的方案数,也可以理解为就是i的j划分方案数

   对于f(i,j)分4种状态

   1.

     (a)当i==1,无论j为多少,情况只有一种划分{1}

     (b)当j==1 ,  无论i为多少,情况同样也只有一种划分{1,1,1,1...,1}

  2.当i==j时,分两种情况:

     (a)如果将i拆分成包含j的累加,那么只有一种划分{j}

     (b)如果将i拆分成不包含j的累加,那么的划分数里最大的数一定比i小,也就相等于i的(i-1)划分方案数

所以这里f(i,j)   = 1+f(i,i-1);

      3.当i<j时,由于划分的数不能出现负数,例如(7!=8-1),所以就相当于求f(i,i)即i的i划分方案数.

      4.当i>j时,同理分两种情况:

     (a)如果将i拆分成包含j的累加,例如{j,{x1,x2,x3...}},那么{x1,x2,x3...}=i-j,那么后面在{x1,x2,x3...还可能出现}j的情况,即相当样例(4 = 2 + 1+1;,4=2+2),这里就是相当于求(i-j)的j划分,即f(i-j,j);

  (b)反之,如果不包含j,即所以划分数都比j小,就转变求(i,j-1)的方案数.

那么这里就是 f(i,j) = f(i,j-1)+f(i-j,j)

对于f(i,j)总结得出:

(1)当i==1||j==1时  f(i,j) = 1              

(2)当i==j时   f(i,j) =  1+f(i,i-1)

(3)当i<j时,     f(i,j) =  f(i,i)

(4)当i>j时,     f(i,j) = f(i-j,j)+f(i,j-1) 

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
int dp[150][150];
int main(){
    int n;
    while(cin>>n){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){
            dp[1][i]=dp[i][1]=1;
        }
        for(int i=2;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(j==i) dp[i][j]=dp[i][j-1]+1;
                else if(i>j) dp[i][j]=dp[i-j][j]+dp[i][j-1];
                else dp[i][j]=dp[i][i];
            }
        }
        cout<<dp[n][n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值