[整数拆分] Ignatius and the Princess III

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

题目大意

对某个整数n拆分,问一共有多少种拆分的方法

题目解析

这是一个母函数的板子题,但是今天我们来用dp来做一下
用一个一维数组dp来记录,dp【j】表示拆分j有多少种方法。我们对dp数组进行n次更新,第i次表示前i个数来组合会有多少中方法,dp[j]+=dp[j-i],意思就是我们的dp[j]中已经记录了前i-1个数组成j的个数,现在的dp[j]再加上dp[j-i]即可,因为是从前往后更新,所以每个数都有机会使用多次,跟多重背包有异曲同工之妙。

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=130;

int n;
int dp[maxn];

int main(){
	while(scanf("%d",&n)!=EOF){
		memset(dp,0,sizeof dp);
		dp[0]=1;
		for(int i=1;i<=n;i++){
			for(int j=i;j<=n;j++)
				dp[j]+=dp[j-i]; 
		}
		cout<<dp[n]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值