20150419武大邀请赛之网络赛 F - Subtract

Description
The number A is connected by n numerical digit a1a2a3a4……an.
You can separate it into two parts as a1a2a3..ak and ak+1ak+2…an and subtract the smaller one from the bigger one to get the number B.
Please find the minimum result of number B.

Input

First line of each case contains a number A.( 10 <= A <= 10^20 )

 

Output

Output the answer in a single line for each case.

 

Sample Input
457
75462

734794666

 

Sample Output
38
387

68813

 

先开始想着分奇偶从中间截取两段,这样相减一定最小,但是之后举出了反例1001,于是还是每个位置都截一下做比较了。

 

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
using namespace std;

int main()
{
    long long  n;
    while(cin >> n)
    {
        long long a,b,c = 1e18;
        long long  temp = 10,i;
        for(i = 0; temp < n ; i++)      //从第i个数开始截
        {
            a = n % temp;     //a为截取的前一部分
            b = n / temp;     //b为截取的后一部分
            c = min(c,abs(a - b));
            temp = temp * 10;
        }
        cout << c << endl;
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值