495. Kids and Prizes
Memory limit: 262144 kilobytes
output: standard
ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected M winners. There are N prizes for the winners, each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:
- All the boxes with prizes will be stored in a separate room.
- The winners will enter the room, one at a time.
- Each winner selects one of the boxes.
- The selected box is opened by a representative of the organizing committee.
- If the box contains a prize, the winner takes it.
- If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).
- Whether there is a prize or not, the box is re-sealed and returned to the room.
The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number of prizes given (the certificates are not counted as prizes, of course).
The first and only line of the input file contains the values of N and M ().
The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10-9.
sample input | sample output |
5 7 | 3.951424 |
sample input | sample output |
4 3 | 2.3125 |
这个问题不是很难想
虽然是期望dp,但是这个问题感觉当做概率dp做更容易
首先求每个盒子的东西被拿走了,那概率很难求
但是反过来,求每个盒子东西没有被拿走的概率就很容易
因为每个盒子都是1,因此拿走的期望也就是这些概率的和
第二种想法就是逐个的推概率
第一次一定可以拿走东西dp[1]=1;
之后就分两种情况,又拿走了一个,和没有拿走(分别有一定的概率)
没有拿走的话,概率同上一个人,拿走了的话,概率比上一个人低1/礼物数
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int M=100005;
double p[M];
int main()
{
int pri,n;
while(scanf("%d%d",&pri,&n)!=EOF)
{
memset(p,0,sizeof(p));
p[1]=(double)1;
double ex=1;
for(int i=2;i<=n;i++)
{
p[i]=(1-p[i-1])*p[i-1]+p[i-1]*(p[i-1]-(double)1/pri);
ex+=p[i];
}
printf("%.9lf\n",ex);
}
return 0;
}
最后最正统的期望做法,暂时没有想法,以后有的话会补充