UVA_10534_WavioSequence

10534 - Wavio Sequence

Time limit: 3.000 seconds

Wavio is a sequence of integers. It has some interesting properties.
Wavio is of odd length i.e. L = 2 n + 1.
The rst (n + 1) integers of Wavio sequence makes a strictly increasing sequence.
The last (n + 1) integers of Wavio sequence makes a strictly decreasing sequence.
No two adjacent integers are same in a Wavio sequence.
For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an Wavio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is
not a valid wavio sequence. In this problem, you will be given a sequence of integers. You have to nd
out the length of the longest Wavio sequence which is a subsequence of the given sequence. Consider,
the given sequence as :
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.
Here the longest Wavio sequence is : 1 2 3 4 5 4 3 2 1. So, the output will be `9'.
Input
The input le contains less than 75 test cases. The description of each test case is given below. Input
is terminated by end of le.
Each set starts with a postive integer, N (1 N 10000). In next few lines there will be N
integers.
Output
For each set of input print the length of longest wavio sequence in a line.
Sample Input
10
1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5
Sample Output
9
9
1

一个最长上升子序列的问题

枚举中心的点然后求左边的最长上升和右边的最长下降

则中心能构成的最大的要求串就是对应的最长上升和最长下降的最小值

这个题目卡掉了最长上升O(N^2)的算法

需要用O(nlogn)的算法

思想就是往一个空的数组中加入值

每当加入一个新的数值的时候找到一个大于等于目前的数值的最前节点更新为新的数值

这个更新位置之前的数字个数+1就是这个点结尾的最长上升子序列长度


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=1e4+5;
int num[M];
int dp[M];
int dp2[M];
int dpn[M];

int bs(int k,int n)
{
    int lo=0,hi=n-1;
    int mid,ans=n;
    while(lo<=hi)
    {
        mid=(lo+hi)/2;
        if(dpn[mid]==k)
            return mid;
        else if(dpn[mid]<k)
            lo=mid+1;
        else
        {
            hi=mid-1;
            ans=min(ans,mid);
        }
    }
    return ans;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dpn,0,sizeof(dpn));
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        int nn=1;
        for(int i=1;i<=n;i++)
        {
            dp[i]=bs(num[i],nn)+1;
            dpn[dp[i]-1]=num[i];
            nn=max(nn,dp[i]);
            //cout<<"i "<<i<<" "<<dp[i]<<" "<<dp2[i]<<endl;
        }
        nn=1;
        memset(dpn,0,sizeof(dpn));
        for(int i=n;i>=1;i--)
        {
            dp2[i]=bs(num[i],nn)+1;
            nn=max(nn,dp2[i]);
            dpn[dp2[i]-1]=num[i];
        }

        int ans=0;
        for(int i=1;i<=n;i++)
            ans=max(ans,min(dp[i],dp2[i]));
        printf("%d\n",ans*2-3);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值