Wavio Sequence

题目描述

Wavio is a sequence of integers. It has some interesting properties.

·  Wavio is of odd length i.e. L = 2*n + 1.

·  The first (n+1) integers of Wavio sequence makes a strictly increasing sequence.

·  The last (n+1) integers of Wavio sequence makes a strictly decreasing sequence.

·  No two adjacent integers are same in a Wavio sequence.

For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an Wavio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is not a valid wavio sequence. In this problem, you will be given a sequence of integers. You have to find out the length of the longest Wavio sequence which is a subsequence of the given sequence. Consider, the given sequence as :

1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.


Here the longest Wavio sequence is : 1 2 3 4 5 4 3 2 1. So, the output will be 9.

输入

The input file contains less than 75 test cases. The description of each test case is given below: Input is terminated by end of file.

 

Each set starts with a postive integer, N(1<=N<=10000). In next few lines there will be N integers.

输出

For each set of input print the length of longest wavio sequence in a line. 

样例输入


1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5

样例输出

9
9
1
#include<bits/stdc++.h>
using namespace std;

int n;
int a[10001];
int dp1[10001];
int dp2[10001]; 
int i,j;
int m;

int main()
{
	while(~scanf("%d",&n))
	{
	    m=1;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			dp1[i]=dp2[i]=1;
		}
		for(i=1;i<n;i++)
		{
			for(j=0;j<i;j++)
			{
				if(a[i]>a[j])
				{
					dp1[i]=max(dp1[i],dp1[j]+1);
				}
			}
		}
		for(i=n-2;i>=0;i--)
		{
			for(j=n-1;j>i;j--)
			{
				if(a[i]>a[j])
				{
					dp2[i]=max(dp2[i],dp2[j]+1);
				}
			}
		}
		for(i=0;i<n;i++)
		{
			if(dp2[i]>2)
				m=max(dp1[i]+dp2[i]-1,m);
		}
		printf("%d\n",m);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值