UVA_10566_CrossedLadders

10566 - Crossed Ladders

Time limit: 3.000 seconds


A narrow street is lined with tall buildings. An
x foot long ladder is rested at the base of the
building on the right side of the street and leans
on the building on the left side. A y foot long
ladder is rested at the base of the building on the
left side of the street and leans on the building on
the right side. The point where the two ladders
cross is exactly c feet from the ground. How wide
is the street?
Input
Each line of input contains three positive 
oating
point numbers giving the values of x, y, and c.
Output
For each line of input, output one line with a 
oating point number giving the width of the street in
feet, with three decimal digits in the fraction.
Sample Input
30 40 10
12.619429 8.163332 3
10 10 3
10 10 1
Sample Output
26.033
7.000
8.000
9.798


问题已知如图

这个问题从已知求解有困难

但是反过来想

所求d如果知道了那么很容易求对应的c

而且d越大c越小

于是可以通过二分答案解决


#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

const double PI=acos(-1.0);
const double EPS=1e-7;

double x,y,c;

bool isbig(double d)
{
    double hx=sqrt(x*x-d*d);
    double hy=sqrt(y*y-d*d);
    if(hx*hy/(hx+hy)>=c)
        return 1;
    else
        return 0;
}

double bs()
{
    double lo=0,hi=min(x,y);
    double mid;
    while(hi-lo>=EPS)
    {
        mid=(hi+lo)/2;
        if(isbig(mid))
            lo=mid;
        else
            hi=mid;
    }
    return lo;
}

int main()
{
    while(scanf("%lf%lf%lf",&x,&y,&c)!=EOF)
    {
        printf("%.3lf\n",bs());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值