uva 10566 Crossed ladders(二分 + 几何)

Crossed ladders

Time Limit: 1000ms
Memory Limit: 32768KB

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?


Input

Each line of input contains three positive floating point numbers giving the values of   x,   y, and   c.

Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

Sample Input

30 40 10
12.619429 8.163332 3
10 10 3
10 10 1

Sample Output

26.033
7.000
8.000

9.798

第一次做二分加几何的题目,心里很激动啊,可惜比赛的时候一直在能直接得到答案的几何关系

#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#define eps 1e-9
using namespace std;

double x,y,c;

double Binary_search(double mid){
    return 1-c/sqrt(x*x-mid*mid)-c/sqrt(y*y-mid*mid);
}

int main(){
    double l,r,mid;
    while(cin>>x>>y>>c){
        l=0.00;
        r=min(x,y);
        while(r-l>eps){
            mid=(l+r)/2;
            if(Binary_search(mid)>0)
                l=mid;
            else
                r=mid;
        }
        printf("%.3lf\n",mid);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值