HDU_1711_NumberSequence

5 篇文章 0 订阅

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18002    Accepted Submission(s): 7874


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 

Recommend
lcy


KMP的裸题


#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
using namespace std;

const int MN=1e6+5;
const int MM=1e4+5;

int s1[MN],s2[MM];
int nex[MM];
int f;

void getnext(int m)
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<m)
    {
        if(k==-1||s2[k]==s2[j])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
int getp(int m,int n)
{
    int j=0,k=0;
    while(j<n)
    {
        if(k==-1||s2[k]==s1[j])
        {
            k++;j++;
        }
        else
            k=nex[k];
        if(k==m)
            return j-m+1;
    }

    return -1;
}

int main()
{
    int t;
    int n,m;
    scanf("%d",&t);
    while(t--)
    {
        f=-1;
        memset(nex,0,sizeof(nex));
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&s1[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&s2[i]);
        getnext(m);
        //for(int i=0;i<10;i++)
        //   cout<<i<<" "<<nex[i]<<endl;
        printf("%d\n",getp(m,n));

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值