HDU_1712_ACboyNeedsYourHelp(分组背包)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6204    Accepted Submission(s): 3410


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6

题意

有一些课

每种课上不同的时间会有不同的收益

但是每种课的及对应上的时间只能选一次。

问最大收益


解题思路

由于每种课只能选择一种时间

因此就是裸的分组背包


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=105;
const int MG=105;
int ng,mv;//组数
int dp[M];

struct Group
{
    int n;//组中元素个数
    int vi[M],wi[M];
    //物品号 占空间 价值
}group[MG];

void gp()//分组背包
{
    for(int i=1;i<=ng;i++)
        for(int j=mv;j>=0;j--)
        {
            for(int k=1;k<=group[i].n;k++)
                if(j>=group[i].vi[k])
                    dp[j]=max(dp[j],dp[j-group[i].vi[k]]+group[i].wi[k]);
        }
}

int main()
{
    int n,m;
    while(1)
    {
        scanf("%d%d",&n,&m);
        if(!n&&!m)
            break;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            group[i].n=m;
            for(int j=1;j<=m;j++)
            {
                group[i].vi[j]=j;
                scanf("%d",&group[i].wi[j]);
            }
        }
        ng=n;mv=m;
        gp();
        printf("%d\n",dp[m]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值