HDU 5791 Two (DP)

41 篇文章 1 订阅
10 篇文章 0 订阅

Two

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 540    Accepted Submission(s): 242

Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.

Input
The input contains multiple test cases.
For each test case, the first line cantains two integers N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
Output
For each test case, output the answer mod 1000000007.
Sample Input
  
  
3 2 1 2 3 2 1 3 2 1 2 3 1 2
Sample Output
  
  
2 3
Author
ZSTU
Source
Recommend
wange2014   |   We have carefully selected several similar problems for you:  5792 5790 5789 5788 5787 

题意:给你a,b两个数组,问你有多少个公共子序列。

题解:DP。
设dp[ i ][ j ]表示a中前i个和b中前j个并且a[i]==b[j]匹配的子序列个数。
那么dp[ i ][ j ] = dp[ i-1 ][ j ]+dp[ i ][ j-1 ]-dp[ i-1 ][ j-1 ]。
a[ i ]=b[ j ]时,dp[ i ][ j ]+=dp[ i-1 ][ j-1 ]+1
注意dp转移时要特殊处理一下。这题就可以了。

AC代码:
#include<bits/stdc++.h>
using namespace std;
const int N=1010;
typedef long long LL;
const long long mod=1000000007;
LL dp[N][N],sum1[N][N],sum2[N][N];
int a[N],b[N];
int main()
{
	int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++) dp[i][j]=0;
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=m;i++) scanf("%d",&b[i]);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                dp[i][j]=dp[i-1][j]+dp[i][j-1]-dp[i-1][j-1];
                if(a[i]==b[j]) dp[i][j]+=dp[i-1][j-1]+1;
                if(dp[i][j]<0) dp[i][j]+=mod; //注意要加 mod,因为上面的dp有可能会减成负数 
                if(dp[i][j]>=mod) dp[i][j]%=mod;
            }
        }
       printf("%I64d\n",dp[n][m]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值