hdu 5791 two

18 篇文章 0 订阅
Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers  N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

Output
For each test case, output the answer mod 1000000007.
 

Sample Input
  
  
3 2 1 2 3 2 1 3 2 1 2 3 1 2
 

Sample Output
  
  
2 3
dp[i][j]表示A序列前i个数和B序列前j个数的相同子序列对有多少个。复杂度 O(n^2)O(n2

)


#include <cstdio>
#include <iostream>

using namespace std;
const long long MOD=1000000007;
int a[1010],b[1010];
long long dp[1010][1010],up[1010][1010],le[1010][1010];
int main(){
   int n,m;

   while(~scanf("%d%d",&n,&m)){
      for(int i=1;i<=n;i++) scanf("%d",&a[i]);
      for(int i=1;i<=m;i++) scanf("%d",&b[i]);
      for(int i=0;i<=n;i++) for(int j=0;j<=m;j++) dp[i][j]=up[i][j]=le[i][j]=0;
      long long ans=0;
      for(int i=1;i<=n;i++){
        for(int j=1;j<=m;j++){
            if(a[i]==b[j]){
                //dp[i][j]=(dp[i-1][j]%MOD+dp[i][j-1]%MOD+1)%MOD;
                dp[i][j]=(le[i-1][j-1]+1)%MOD;
                up[i][j]=(up[i-1][j]+dp[i][j])%MOD;
                le[i][j]=(le[i][j-1]+up[i][j])%MOD;
            }
            else{
                up[i][j]=up[i-1][j];
                le[i][j]=(le[i][j-1]+up[i-1][j])%MOD;
            }
            ans=(ans+dp[i][j])%MOD;
        }
      }
      printf("%I64d\n",ans%MOD);
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值