poj 1734

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.        

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.      

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).      

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.      

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2
题目大意:n个点,m条边的加权无向图,求其中的最小环,并输出路径

 题目分析:Floyd的应用,很棒的应用,要求最小环,首先要找到环,找到的办法就是判断d[i][j] + map[i][k] + map[k][j] < INF是否成立,因为Floyd是按照结点的顺序更新最短路的,所以我们在更新最短路之前先找到一个连接点k,当前的点k肯定不存在于已存在的最短路d[i][j]的路径上,因为我们还没用这个k去更新最短路,相当于 (i -> k -> j -> j到i的最短路 -> i)这样一个环就找到了,接下来我们要记录路径,用path[i][j]表示在最短路i到j的路径上j的前一个结点,所以我们在更新最短路时也要更新这个点,原来的最短路是i -> j,现在变成了 i -> k -> j,所以有path[i][j] = path[k][j],因为要找最小环,所以不断更新找到环的权值,环更新一次,路径也要更新一次,路径更新时根据path数组迭代一下就ok了
#include <iostream>

using namespace std;
#define inf 0xfffffff
int d[110][110],map[110][110],path[110][110];
int n,m,ans[110],mi,cnt;
void init()
{
  for(int i=1;i<=n;i++)
  {
   for(int j=1;j<=n;j++)
   {
    d[i][j]=inf;
    map[i][j]=inf;
    path[i][j]=i;
   }
  }
}
void floyd()
{
 mi=inf;
 for(int k=1;k<=n;k++)
 {
  for(int i=1;i<k;i++)
  {
   for(int j=1;j<i;j++)
   {
    if(d[i][j]+map[i][k]+map[k][j]<mi)
    {
    //此时的k值不在d[i][j]的路径中,所以找到一个环
     mi=d[i][j]+map[i][k]+map[k][j];
     //记录路径把j当起点顺序是: j -> j到i最短路的路径 -> i -> k
     int tmp=j;
     cnt=0;
     while(tmp!=i)
     {
      ans[cnt++]=tmp;
      tmp=path[i][tmp];
     }
     ans[cnt++]=i;
     ans[cnt++]=k;
    }
   }
  }
  for(int i=1;i<=n;i++)
  {
   for(int j=1;j<=n;j++)
   {
    if(d[i][j]>d[i][k]+d[k][j])
    {
     d[i][j]=d[i][k]+d[k][j];
      //path[i][j]表示i到j最短路径上j前面的一个点 
    //所以此时i到j的最短路径上j前一个点为k到j最短路径上j的前一个点
     path[i][j]=path[k][j];
    }
   }
  }
 }
}
int main()
{
    int u,v,w;
    cin>>n>>m;
    init();
    for(int i=0;i<m;i++)
    {
    cin>>u>>v>>w;
    if(d[u][v]>w)//找最小环遇到平行边时取其最小边权
    {
    d[u][v]=d[v][u]=w;
    map[u][v]=map[v][u]=w;
    }
    }
    floyd();
    if(mi==inf)
    cout<< "No solution." <<endl;
    else
    {
     cout<<ans[0]<<" ";
     for(int i=1;i<cnt;i++)
     {
      cout<<" "<<ans[i];
     }
     cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值