hdu 3501

Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
0 2
 

Author
GTmac
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3507  3506  3505  3504  3499 

欧拉函数

 

     对正整数n,欧拉函数是少于或等于n的数中与n互质的数的数目。例如euler(8)=4,因为1,3,5,7均和8互质。
     Euler函数表达通式:euler(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…(1-1/pn),其中p1,p2……pn为x的所有素因数,x是不为0的整数。euler(1)=1(唯一和1互质的数就是1本身)。
     欧拉公式的延伸:一个数的所有质因子之和是euler(n)*n/2。
     欧拉函数的实现也非常的简单,在原有的素因子分解基础上,利用一下迭代就好了。

     这个题就是前n-1项的和再减去euler(n)*n/2,结果在求个模就行了
#include <iostream>

using namespace std;
long long euler(long long n)
{
  long long res=n,a=n;
  for(int i=2;i*i<=a;i++)
  {
   if(a%i==0)
   {
    res=res/i*(i-1);//先进行除法是为了防止数据的溢出
    while(a%i==0) a/=i;
   }
  }
  if(a>1) res=res/a*(a-1);
  return res;
}
int main()
{
    long long n,num,ans;
    while(cin>>n&&n!=0)
    {
     num=euler(n);
     num=n-1-num;
     ans=num*n/2;
     cout<<ans%1000000007<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值