hdu 4430 Yukari's Birthday


Yukari's Birthday

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6314    Accepted Submission(s): 1520


Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
 

Output
For each test case, output r and k.
 

Sample Input
  
  
18 111 1111
 

Sample Output
  
  
1 17 2 10 3 10
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define LL long long
using namespace std;
LL mypow(LL x,LL y){
    LL ans = 1;
    while(y){
        if(y&1) ans *= x;
        y >>= 1;
        x *= x;
    }
    return ans;
}
int main() {
    LL n,r,k,lt,rt,mid;
    while(~scanf("%I64d",&n)){
        r = 1;
        k = n-1;
        for(int i = 2; i <= 41; i++){
            lt = 2;
            rt = (LL)pow(n,1.0/i);
            while(lt <= rt){
                mid = (lt+rt)>>1;
                LL sum = (mid-mypow(mid,i+1))/(1-mid); //二分。根据等比数列,可知x(1-xn) = k*(1-x)
                if(sum == n||sum == n-1){
                    if(i*mid < r*k){
                        r = i;
                        k = mid;
                    }
                    break;
                }else if(sum < n) lt = mid+1;
                else rt = mid-1;
            }
        }
        printf("%I64d %I64d\n",r,k);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值