HDU 4430 Yukari's Birthday(枚举+二分)

Yukari's Birthday

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6103    Accepted Submission(s): 1438


Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
 

Output
For each test case, output r and k.
 

Sample Input
  
  
18 111 1111
 

Sample Output
  
  
1 17 2 10 3 10

题意:有n个蜡烛,插成同心圆,中心可插可不插,一共r圈,第i圈插k^i个。求r*k最小的一组

解决:先枚举r,再二分k

细节:数据大小,二分注意判断更改左端右端。

#include <stdio.h>  
#include <string.h>  
#include <math.h>  
#include <algorithm>  
using namespace std;  
#define ll long long  
  
ll n;  
  
ll bin(ll s)  
{  
    ll l = 2,r = n,mid,i;  
    while(l<=r)  
    {  
        mid = (l+r)/2;  
        ll sum = 1,ans = 0;;  
        for(i = 1; i<=s; i++)  
        {  
            if(n/sum<mid)  
            {  
                ans = n+1;  
                break;  
            }  
            sum*=mid;  
            ans+=sum;  
            if(ans>n)//放置溢出  
                break;  
        }  
        if(ans == n || ans == n-1) return mid;  
        else if(ans<n-1) l = mid+1;  
        else r = mid-1;  
    }  
    return -1;  
}  
  
int main()  
{  
    ll s,k,l,r,mid,i;  
    while(~scanf("%I64d",&n))  
    {  
        l = 1,r = n-1;  
        for(i = 2; i<=45; i++)  
        {  
            k = bin(i);  
            if(k!=-1 && i*k<l*r)  
            {  
                l = i,r = k;  
            }  
        }  
        printf("%I64d %I64d\n",l,r);  
    }  
  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值