POJ 2229 Sumsets(计数dp)

Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input
A single line with a single integer, N.

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

分析

dp[i]:数字i的最多组合数
若i是奇数:i的任意一个组合都包含1,所以dp[i] = dp[i-1]
若i是偶数:i-1是奇数,任意一个组合加1构成i的组合,除了这些组合之外,i的其他组合都不包含1,意味着全部是偶数,则i/2的每个组合乘以2可以构成i的一个组合
所以dp[i]=dp[i-1]+dp[i>>1]

/*===============================================================
*   Copyright (C) 2016 All rights reserved.
*   
*   文件名称:B.cpp
*   创 建 者:gsh
*   创建日期:2016年08月10日
*   描    述:2的幂数 dp
*   更新日志:
*
================================================================*/
#include <iostream>
#include <cstdio>
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
const int maxn = 1000001;
const int MOD = 1000000000;
ll a[maxn];
int main()
{
    int n;
    while(scanf("%d",&n) != EOF)
    {
         a[0] = 1;
         for(int i = 1; i <= n; i++)
         {
            if(i&1) a[i] = a[i-1];
            else a[i] = (a[i-1] + a[i >> 1]) % MOD;
         }
        printf("%d",a[n]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值