POJ2229Sumsets 递推水题

一叶落寞,万物失色

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output


6
题目大意:
求给出的N换成若干个整数的和的方式有多少种
考虑一个奇数X我们可以想到:对于X可以从X-1加上个1转移而来,对于偶数我们容易想到它的两种转移方式,一种从X、2,一种为X-1
一个O(n)的递推就好啦,记得mod,会wa
代码:
#include <cstring>
#include <cstdio>
using namespace std;
char a[1003];
int sum[507];
int f[1000007];
int main()
{
    int n;
    scanf("%d",&n);
    f[1]=1;
    f[2]=2;
    for(int i=3;i<=n;i++)
    {
        if(i&1) f[i]=f[i-1];
        else {
            f[i]=(f[i-1]+f[i/2])%1000000000;
        }

    }
    printf("%d",f[n]);
 return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值