LightOJ - 1236质因子分解+LCM

Find the result of the following code:

long long pairsFormLCM( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
       
 for( int j = i; j <= n; j++ )
           
if( lcm(i, j) == n ) res++; // lcm means least common multiple
   
 return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).


Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

这个题我一开始怕不是想到天边去了………………

设n=p1^e1*p2^e2*p3^e3*.....^pn^en.

则,当a,b的LCM(a,b)==n时

令a=p1^a1*p2^a2*...*pn^an

b=p1^b1*p2^b2*...*pn^bn

(ai,bi可为0)

则有max(a1,b1)=e1……max(ai,bi)=ei……max(an,bn)=en

这样的ai,bi取值的方案数为s=(2*(ei+1)-1)种,然后乘起来得到ans,然后ans=ans/2+1,加1应该是因为LCM(n,n)不会重复(应该吧……)

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long LL;
const int MAXN=1e7+9;
#define fi first
#define se second


int prime[700000-23],total;
bool isprime[MAXN];

void make()
{
    int m=MAXN-3;
    memset(isprime,true,sizeof(isprime));
    isprime[0]=isprime[1]=false;
    total=0;
    for(int i=2;i<=m;i++)
    {
        if(isprime[i])prime[++total]=i;
        for(int j=1;j<=total&&prime[j]*i<=m;j++)
        {
            isprime[prime[j]*i]=false;
            if(i%prime[j]==0)break;
        }
    }
    memset(isprime,false,sizeof(isprime));
    for(int i=1;i<=total;i++)isprime[prime[i]]=true;
}

int main()
{
    make();
    int T,cas=0;
    //cout<<total;
    scanf("%d",&T);

    while(T--)
    {
        LL n;
        scanf("%lld",&n);
        LL ans=1;
        for(int i=1;i<=total&&prime[i]*prime[i]<=n;i++)
        {
            LL s=0;
            if(n%prime[i]==0)
            {
                while(n%prime[i]==0)
                {
                    n/=prime[i];
                    s++;
                }
            }
            ans*=(s+1)*2-1;
        }
        if(n>1)ans*=3;
        printf("Case %d: %lld\n",++cas,ans/2+1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值