LightOJ - 1234 (介绍一下欧拉常数,虽然没什么关系。。。)

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.


Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139


这个题我一开始是以为用的欧拉常数,但是如果我把暴力区间定在a*1e6(a为整数),后面开始用欧拉常数算的话,a太小就达不到欧拉常数要求的极限值导致计算的值很不准确,a太大就导致前面暴力求和的部分太多TLE,如果用较大的a打表的话又会MLE(毕竟32M里存太大的double数组。。。)

其实还是打表,只不过是100个100个来打,比如sum[1]表示的是1+1/2+...+1/100的值,然后输入n找到一个整百值向上暴力顶多100个数.........(感觉被套路了)

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long LL;
const int MAXN=1e7+9;
#define fi first
#define se second

double n;

double a[1000000+233];


int main()
{
    int T,cas=0;
    scanf("%d",&T);
    double s=0;
    for(int i=1;i<=100000000;i++)
    {
        s+=1.0/(double)i;
        if(i%100==0)
        {
            a[i/100]=s;
        }
    }
    while(T--)
    {
        int m;
        scanf("%d",&m);
        int z=m/100;
        double ans=a[z];
        for(int i=z*100+1;i<=m;i++)
        {
            ans+=1.0/(double)i;
        }
        printf("Case %d: %.10lf\n",++cas,ans);
    }
    return 0;
}
欧拉常数:约为eluer=0.57721566490153286060651209

调和级数

是发散的

但是式子       存在极限,这个极限就是欧拉常数(证明过程百度百科有但是我看不懂)

总之,当n很大的时候,你的调和级数可以用ln(n)+eluer来计算,比如上题1e7就可以算了

本人蒟蒻,如有错误,还望指正



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值