【搜索-广搜】poj3984 迷宫问题

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18957 Accepted: 11193

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source

[Submit]   [Go Back]   [Status]   [Discuss]

代码:

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;

typedef pair<int ,int> P;
const int inf=100000000;
int maze[5][5],d[5][5];
P record[5][5];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};

int bfs()
{
    queue<P> que;

    for(int i=0;i<5;i++)
        for(int j=0;j<5;j++)
        d[i][j]=inf;
    que.push(P(0,0));
    d[0][0]=0;
    while(que.size())
    {
        P p=que.front();que.pop();
        if(p.first==4&&p.second==4)
            break;

        for(int i=0;i<4;i++)
        {
            int nx=p.first+dx[i],ny=p.second+dy[i];
            if(nx>=0&&nx<5&&ny>=0&&ny<5&&d[nx][ny]==inf&&maze[nx][ny]!=1)
            {
                record[nx][ny].first=p.first; 
                record[nx][ny].second=p.second;       //记录状态点的前驱;
                que.push(P(nx,ny));
                d[nx][ny]=d[p.first][p.second]+1;
            }
        }
    }
    return d[4][4];
}

int main()
{
    for(int i=0;i<5;i++)
        for(int j=0;j<5;j++)
          scanf("%d",&maze[i][j]);
    P route[10];       //绘制途径;
    int x=4,y=4,k1;
    int k=bfs();       //剩下代码还可以再优化,不过下述代码比较方便理解;
    k1=k;
    while(k--)                                                  
    {
        route[k].first=record[x][y].first;
        route[k].second=record[x][y].second;
        x=route[k].first,y=route[k].second;
    }
    for(int i=0;i<k1;i++)
        printf("(%d, %d)\n",route[i].first,route[i].second);
        printf("(4, 4)");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值