HDU5873 Football Games

题目

Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2176    Accepted Submission(s): 799


Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
  
  At the first phase of the championships, teams are divided into  M  groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 

Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers  M , which is the number of groups.
  The  i -th of the next  M  lines begins with a positive integer  Bi  representing the number of teams in the  i -th group, followed by  Bi  nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output  M  lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 

Sample Input
  
  
2 3 0 5 1 2 1 1
 

Sample Output
  
  
F T

题意


  输入M有几个样例

 下面M行,第一个数代表后面几个输入,后面输入这个队伍在这一轮的得分,我们需要判断的是这一轮的得分是否正确,错误输出F,正确输入T.


解题思路


首先把这一轮的得分从小到大排序,我们可以知道这一轮的总得分是n*(n-1)

得分最多的队伍这一轮的得分是2*(n-1),那么剩下的队伍的得分总和最小为min(n-1)=n*(n-1)-2*(n-1)=(n-1)*(n-2);

得分第二多的对外本轮的得分是2*(n-2),那么剩下的队伍的得分总和最小为min(n-2)=(n-1)*(n-2)-2*(n-2)=(n-2)*(n-3);

我们归纳之后可以发现,我们从得分最小的队伍开始累加,发现sum(i)>=i*(i-1);

这是小于的边界,我们可以发现他也有个最大的界限

得分最多的队伍这一轮得分最小也就是(n-1),

这一种情况实际上是每一队的得分都一样都是(n-1),也就是每一队都打平

这时候sum(i)<=i*(n-1)

这样子公式就出来了

i*(i-1)<=sum(i)<=i*(n-1)


这世界dalao的力量真是超乎我的想象

(°—°〃)


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int b[20000+10];
int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        int n;
      while(m--)
      {
          int flag=0;
          scanf("%d",&n);
          for(int i=1;i<=n;i++)
            scanf("%d",b+i);
          sort(b+1,b+n+1);
          int sum=0;
          for(int i=1;i<=n;i++)
          {
              sum+=b[i];
              if(sum>=i*(i-1)&&sum<=i*(n-1))
              {
              }
              else
              {
                flag=1;
                break;
              }
          }
          if(flag)
            printf("F\n");
          else
            printf("T\n");
      }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值