HDU 5873 Football Games 竞赛图

                                             Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3071    Accepted Submission(s): 1069


 

Problem Description

A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced.
  
  At the first phase of the championships, teams are divided into M groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.

 

 

Input

Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers M, which is the number of groups.
  The i-th of the next M lines begins with a positive integer Bi representing the number of teams in the i-th group, followed by Bi nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000

 

 

Output

For each test case, output M lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.

 

 

Sample Input

 

2 3 0 5 1 2 1 1

 

 

Sample Output

 

F T

 

 

Source

2016 ACM/ICPC Asia Regional Dalian Online

 

题解:

F题

Landau's Theorem定理

定理解释与证明

如果没有平手选项, 赢得加一分的话,可以直接用兰道定理解决,将所有的得分s从小到大排序。

\forall 1\leqslant i\leqslant n-1 \sum_{i = 1}^{n} s[i] >= \binom{i}{2}            当i = 1 时  只能取=号。

 

现在加入了平手选项,所以将定理改动一下就可以了(具体证明,目前看不太懂)

将得分s从小到大进行排序

该竞赛图合理需满足两个条件

  • s​1​​+s​2​​+...+s​i​​≥i(i−1), 对于所有的i < n 必须恒成立
  • s1+s2+...+sn=n(n−1)

 

#include <bits/stdc++.h>

using namespace std;
typedef long long LL;
const int maxn = 2e4+100;
const int INF = 0x3f3f3f3f;

int n,T;
int a[maxn];

int main()
{
    while(~scanf("%d",&T))
    {
      while(T--)
    {
      scanf("%d",&n);
      int s = 0;
      bool t = true;
      for(int i = 0; i < n; i++) scanf("%d",&a[i]);
      sort(a,a+n);
      for(int i = 0; i < n; i++)
      {
        s += a[i];
        if(i == n-1) break;
        if(s < 1LL*i*(i+1))
        {t = false; break;}
      }

      if(s != 1LL*n*(n-1))  t = false;
      if(t) printf("T\n");
      else printf("F\n");
    }
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值