PAT Advanced 1135 Is It A Red-Black Tree (30)

该博客主要讨论数据结构中的红黑树特性,包括5条性质,并给出几个示例,说明如何判断一棵二叉搜索树是否符合红黑树的定义。文章提供了若干测试用例并要求根据给定的先序遍历序列判断树是否合法。
摘要由CSDN通过智能技术生成

问题描述:

1135 Is It A Red-Black Tree (30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

AC代码: 

#include<bits/stdc++.h>
using namespace std;
vector<int> v1,v2;
bool flag,first;
int sb;
struct cmp
{
	bool operator() (const int p1,const int p2) const
	{
		return abs(p1)<abs(p2);
	}
};
void dfs(vector<int>::iterator it1,vector<int>::iterator it2,int size,bool red,int black)
{
	if(red&&*it1<0)
	{
		flag=false;
	}
	
	if(flag)
	{
		if(size>1)
		{
			if(*it1>0)
			{
				black++;
				red=false;
			}
			else
			red=true;
			vector<int>::iterator it;
			it=find(it2,it2+size,*it1);
			int l=it-it2;
			int r=it2+size-it-1;
			dfs(it1+1,it2,l,red,black);
			dfs(it1+1+l,it+1,r,red,black);

		}
		else if(size==1)
		{
			if(*it1>0)
			{
				black++;
				red=false;
			}
			else
			red=true;
			if(first)
			{
				first=false;
				sb=black;
			}
			else
			{
				if(sb!=black)
				{
					flag=false;
				}
			}
		}
		else
		{
			if(first)
			{
				first=false;
				sb=black;
			}
			else
			{
				if(sb!=black)
				{
					flag=false;
				}
			}
		}
	}
}
int main()
{
//	freopen("data.txt","r",stdin);
	int n,k,c1,c2,x,t=0;
	vector<int>::iterator it1,it2;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&k);
		t=k;
		v1.clear();
		for(;k--;)
		{
			scanf("%d",&x);
			v1.push_back(x);
		}
		v2=v1;
		sort(v2.begin(),v2.end(),cmp());
		flag=true;		
		first=true;
		sb=0;
		it1=v1.begin();
		it2=v2.begin();
		dfs(it1,it2,t,true,0);
		if(flag)
		printf("Yes\n");
		else
		printf("No\n");
	}
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值