PAT甲级1135 Is It A Red-Black Tree (30 分)

1135 Is It A Red-Black Tree (30 )

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpg

rbf2.jpg

rbf3.jpg

Figure 1

Figure 2

Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (30) which is the total number of cases. For each case, the first line gives a positive integer N (30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3

9

7 -2 1 5 -4 -11 8 14 -15

9

11 -2 1 -7 5 -4 8 14 -15

8

10 -7 5 -6 8 15 -11 17

Sample Output:

Yes

No

No

      题目大意:

     给定k个前序序列,要求判定是否为红黑树。红黑树满足,根为黑结点、红结点的孩子一定是黑色的,任一结点到叶子结点的数目应当相同。

     正值为黑点,负值为红点。

思路:

        由于红黑树也是BST一种,中序有特点,可以用前中序建树,但是其实按照BST的标准建树也可以通过。然后按照给定的特点进行判定即可。

         静态二叉树不好判定何时为叶子结点,或何时有孩子,故用链表。

         如果题目变得更难,其实应该还要区分开+0 与 – 0的,但此题不涉及。

         注意:在判断红结点的左右孩子都应为黑结点的时候,一定要判断是否存储左右孩子再看值,否则会越界的。

参考代码:

 

 

 

 

#include<cstdio>
#include<algorithm>
using namespace std;
int k, n, temp;
struct node{
	int data;
	struct node *l, *r;
} * root;
void Insert(node * & root, int v){
	if(root == NULL){
		root = new node;
		root->data = v;
		root->l = root->r = NULL;
		return;
	}
	if(abs(root->data) <= abs(v)) Insert(root->l, v);
	else Insert(root->r, v);
}
int getnum(node * root){
	if(root == NULL) return 0;
	int l = getnum(root->l);
	int r = getnum(root->r);
	return  root->data > 0? max(l, r) + 1 : max(l, r);
} 
bool judge1(node * root){
	if(root == NULL ) return true;
	if(root->data < 0){
		if(root->l != NULL && root->l->data < 0) return false;
		if(root->r != NULL && root->r->data < 0) return false;
	}
	return judge1(root->l) && judge1(root->r);
}
bool judge2(node * root){
	if(root == NULL) return true;
	int l = getnum(root->l);
	int r = getnum(root->r);
	if(l != r) return false;
	return judge2(root->l) && judge2(root->r);
}
int main(){
	scanf("%d", &k);
	for(int i = 0; i < k; ++i){
		scanf("%d", &n);
		for(int j = 0; j < n; ++j){
			scanf("%d", &temp);
			Insert(root, temp);
		}
		if(root->data > 0 && judge1(root) && judge2(root)) printf("Yes\n");
		else printf("No\n");
		root = NULL;
	}
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/78037334

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值