[COCI2006-2007#2] R2

click here to luogu.org

题目描述

The number S is called the mean of two numbers R1 and R2 if S is equal to (R1+R2)/2. Mirko's birthday present for Slavko was two integers R1 and R2. Slavko promptly calculated their mean which also happened to be an integer but then lost R2! Help Slavko restore R2.

输入输出格式

输入格式:

The first and only line of input contains two integers R1 and S, both between -1000 and 1000.

输出格式:

Output R2 on a single line.

输入输出样例

输入样例#1:   11 15

输出样例#1:   19

输入样例#2:   4 3

输出样例#2:   2

 

c++

#include<iostream>
using namespace std;
int main()
{
	int r1,r2,s;
	cin>>r1>>s;
	r2=s*2-r1;
	cout<<r2;
	return 0;
}

Python

# -*- coding: utf-8 -*-
num = input().split()
r1 = num[0]
s = num[1]
r2 = int(s)*2 - int(r1)
print(r2)

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值