Commando War_UVA 11729

题目

“Waiting for orders we held in the wood, word from the front never came By evening the sound of the gunfire was miles away Ah softly we moved through the shadows, slip away through the trees Crossing their lines in the mists in the fields on our hands and our knees And all that I ever, was able to see The fire in the air, glowing red, silhouetting the smoke on the breeze” There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battlefield. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing in between. Input There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤ N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed. Output For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the total number of seconds counted from the start of your first briefing till the completion of all jobs. Sample Input 3 2 5 3 2 2 1 3 3 3 4 4 5 5 0 Sample Output Case 1: 8 Case 2: 15

 题目大意

你是一名将军,你需要向每一名士兵介绍任务,然后士兵去完成任务

介绍和完成任务都需要话费时间,在前一个士兵去进行任务的同时,你可以给下一名士兵介绍任务

求最小介绍+完成任务时间

算法:贪心 

代码

#include<iostream>
#include<algorithm>
using namespace std;
struct war
{
	int b,j;
	bool operator<(const war& a)const
	{
		return j>a.j;
	}
}a[10000];
int main()
{
	int n;int num=0;
	while(cin>>n&&n)
	{
		for(int i=0;i<n;i++)
			cin>>a[i].b>>a[i].j; 
		sort(a,a+n);
		int ans,t;
		ans=0,t=0;
		for(int x=0;x<n;x++)
		{
			t+=a[x].b;          //这次开始工作的时间
			ans=max(ans,t+a[x].j);  //比较这次开始工作的时间+这次工作所需时间(也就是完成这次工作的总时间) 与 之前的时间 
		}
		cout<<"Case "<<++num<<": "<<ans<<endl;
	}
	
	return 0;
}
//贪心 先执行完成任务时间长的 这样在他完成任务的同时 可以给别人安排
//每个任务开始的时间肯定是 t+a[x]b 之前的介绍时间+这次的介绍时间
//比较这次开始工作的时间+这次工作所需时间(也就是完成这次工作的总时间) 与 之前的时间 
//然后取较大的那一个,如果取较小值,那么这个工作就无法完成 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Cherish_lii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值