HDU - 5187 - zhx's contest

Problem Description
As one of the most powerful brushes, zhx is required to give his juniors  n  problems.
zhx thinks the  ith  problem's difficulty is  i . He wants to arrange these problems in a beautiful way.
zhx defines a sequence  {ai}  beautiful if there is an  i  that matches two rules below:
1:  a1..ai  are monotone decreasing or monotone increasing.
2:  ai..an  are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module  p .
 
Input
Multiply test cases(less than  1000 ). Seek  EOF  as the end of the file.
For each case, there are two integers  n  and  p  separated by a space in a line. ( 1n,p1018 )
 
Output
For each test case, output a single line indicating the answer.
 
Sample Input
  
  
2 233 3 5
 
Sample Output
  
  
2 1
题意:从1~n有多少种排列,使得 a1~ai 满足单调递增或者单调递减,ai~an 满足单调递增或者递减。
分析:从n个数种选出i个数 剩下的数要满足单调递增或者递减或者递减的规律那么方式唯一。
ans = (C(N,0)+C(N,1)+......+C(N,N)) =2^N;但是这种情况下 单调递增和单调递减算了两遍  因此要减2。
ans = 2^n - 2;当n为1时,要输出1,而当p为1时要输出0;
但是n,p都是LL型的,快速幂的时候会爆LL,所以这里要用到快速乘法,快速乘法其实和快速幂差不多,就是把乘号改为加号
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long 
using namespace std;
LL n, p;
LL mul(LL a, LL b) //快速乘法,其实和快速幂差不多 
{	
    LL ret=0;
    while(b) 
    {
        if(b&1) 
        ret=(ret + a)%p;
        a=(a + a)%p;
        b>>=1;
    }
    return ret;
}
LL pow(LL a, LL b) //快速幂 
{	
    LL ret=1;
    while(b) 
    {
        if(b&1) 
        ret=mul(ret,a)%p;
        a=mul(a,a)%p;
        b>>=1;
    }
    return ret;
}
int main() 
{
	while(cin>>n>>p) 
	{
		if(p==1) 
		{
			cout<<0<<endl;
		} 
		else if(n==1) 
		{
			cout<<1 <<endl;
		} 
		else 
		{
			LL ans=pow(2,n)-2;
			if(ans<0) 
			ans+=p;
			cout<<ans<<endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值