Yet Another Story of Rock-paper-scissors(水题)


Yet Another Story of Rock-paper-scissors
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Akihisa and Hideyoshi were lovers. They were sentenced to death by the FFF Inquisition.

 Ryou, the leader of the FFF Inquisition, promised that the winner of Rock-paper-scissors

 would be immune from the punishment. Being lovers, Akihisa and Hideyoshi decided to

 die together with their fists clenched, which indicated rocks in the game. However, at the

 last moment, Akihisa chose paper and Hideyoshi chose scissors. As a result, Akihisa was

 punished by the FFF Inquisition and Hideyoshi survived alone.

When a boy named b and a girl named g are being punished by the FFF Inquisition, they

 will play Rock-paper-scissors and the winner will survive. If there is a tie, then neither

of they will survive. At first, they promise to choose the same gesture x. But actually, the

 boy wants to win and the girl wants to lose. Of course, neither of them knows that the

other one may change his/her gesture. At last, who will survive?

Input

There are multiple test cases. The first line of input is an integer T ≈ 1000

 indicating the number of test cases.

Each test case contains three strings -- bgx. All strings consist of letters

 and their lengths never exceed 20. The gesture x is always one

of"rock""paper" and "scissors".

Output

If there is a tie, output "Nobody will survive".

Otherwise, output "y will survive" where y is the name of the winner.

Sample Input

1
Akihisa Hideyoshi rock

Sample Output

Hideyoshi will survive

代码:

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;

int main()
{
	int T;
	scanf("%d", &T);
	while(T--) {
		string s1, s2, s3;
		cin >> s1 >> s2 >> s3;
		cout << s2 << " will survive" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值