HDU 1285 确定比赛名次(拓扑排序)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1285

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
 
 
4 31 22 34 3
 

Sample Output
 
 
1 2 4 3


题目思路:拓扑排序模板题,用优先队列维护入度为0的点

模板可参见:https://blog.csdn.net/baodream/article/details/80368764

#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>
#include<map>

using namespace std;

#define FOU(i,x,y) for(int i=x;i<=y;i++)
#define FOD(i,x,y) for(int i=x;i>=y;i--)
#define MEM(a,val) memset(a,val,sizeof(a))
#define PI acos(-1.0)

const double EXP = 1e-9;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const ll MINF = 0x3f3f3f3f3f3f3f3f;
const double DINF = 0xffffffffffff;
const int mod = 1e9+7;
const int N = 1e6+5;

int n,m;
int inDeg[N];  //i点的入度
vector<int>vec[N];  //i点的邻接表,即i与哪些点相连
int ans[N];    //排序结果数组

int topSort()    //返回值代表是否有环,排序结果在ans数组
{
    int cnt=0;
    priority_queue<int,vector<int>,greater<int> >q;
    while(!q.empty())
        q.pop();
    for(int i=1;i<=n;i++)
        if(inDeg[i]==0)
            q.push(i);
    while(!q.empty())
    {
        int now = q.top();
        q.pop();
        ans[++cnt]=now;     //个数+1并存数组
        int len = vec[now].size();
        for(int i=0;i<len;i++)
        {
            inDeg[vec[now][i]]--;
            if(inDeg[vec[now][i]]==0)
                q.push(vec[now][i]);
        }
    }
    return (cnt==n)?1:0;  //是否等于n,等于n代表无环
}

void init()  //输入数据,n个点,m条边
{
    int x,y;
    for(int i=1;i<=n;i++)
        vec[i].clear();
    memset(inDeg,0,sizeof(inDeg));
    for(int i=1;i<=m;i++)
    {
        cin>>x>>y;
        inDeg[y]++;
        vec[x].push_back(y);
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    std::ios::sync_with_stdio(false);
    int t;
    while(cin>>n>>m)
    {
        init();
        topSort();
        for(int i=1;i<=n;i++)
            printf("%d%c",ans[i],(i==n)?'\n':' ');
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值