floyd算法汇率

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No
//Memory Time 
//276K   79MS 

#include <iostream>
#include<map>
#include<string>
using namespace std;

const int inf=10000;      //无限大
int n;      //货币种类
int m;      //兑换方式

map<string,int>STL;     //建立一个 使字符串与整数有一一对应关系 的容器STL,以便利用邻接矩阵存储数据

double rate;
char str[50],str1[50],str2[50];
double dist[31][31];

int i,j,k;

void floyd(void)
{
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                if(dist[i][j] < dist[i][k] * dist[k][j])       //变形的最大路径,变"+"为"*"
                    dist[i][j] = dist[i][k] * dist[k][j];
    return;
}

int main(void)
{
    int cases=1;
    while(cases)
    {
        /*Initial*/

        memset(dist,inf,sizeof(dist));

        /*Input*/

        cin>>n;
        if(!n)break;

        for(i=1;i<=n;i++)
        {
            cin>>str;
            STL[str]=i;          //将输入的货币从1到n依次编号
            dist[i][i]=1;        //到自身的转换率默认为1,但通过floyd可能会被改变
                                 //有向图的顶点(一般)存在环
        }

        cin>>m;
        for(i=1;i<=m;i++)
        {
            cin>>str1>>rate>>str2;
            dist[STL[str1]][STL[str2]]=rate;      //构造图
        }

        /*Floyd Algorithm*/

        floyd();

        /*Output*/

        int flag=false;
        for(i=1;i<=n;i++)
            if(dist[i][i]>1)
            {
                flag=true;
                break;
            }
         if(flag)
            cout<<"Case "<<cases++<<": Yes"<<endl;
        else
            cout<<"Case "<<cases++<<": No"<<endl;
    }
    return 0;
}
View Code

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值