CSU 2031 Barareh on Fire(BFS)

Description

The Barareh village is on fire due to the attack of the virtual enemy. Several places are already on fire and the fire is spreading fast to other places. Khorzookhan who is the only person remaining alive in the war with the virtual enemy, tries to rescue himself by reaching to the only helicopter in the Barareh villiage. Suppose the Barareh village is represented by an n × m grid. At the initial time, some grid cells are on fire. If a cell catches fire at time x, all its 8 vertex-neighboring cells will catch fire at time x + k. If a cell catches fire, it will be on fire forever. At the initial time, Khorzookhan stands at cell s and the helicopter is located at cell t. At any time x, Khorzookhan can move from its current cell to one of four edge-neighboring cells, located at the left, right, top, or bottom of its current cell if that cell is not on fire at time x + 1. Note that each move takes one second. Your task is to write a program to find the shortest path from s to t avoiding fire.

Input

There are multiple test cases in the input. The first line of each test case contains three positive integers n, m and k (1 ⩽ n,m,k ⩽ 100), where n and m indicate the size of the test case grid n × m, and k denotes the growth rate of fire. The next n lines, each contains a string of length m, where the jth character of the ith line represents the cell (i, j) of the grid. Cells which are on fire at time 0, are presented by character “f”. There may exist no “f” in the test case. The helicopter and Khorzookhan are located at cells presented by “t” and “s”, respectively. Other cells are filled by “-” characters. The input terminates with a line containing “0 0 0” which should not be processed.

Output

For each test case, output a line containing the shortest time to reach t from s avoiding fire. If it is impossible to reach t from s, write “Impossible” in the output.

Sample Input

7 7 2
f------
-f---f-
----f--
-------
------f
---s---
t----f-
3 4 1
t--f
--s-
----
2 2 1
st
f-
2 2 2
st
f-
0 0 0

Sample Output

4
Impossible
Impossible
1

Hint

Source

ATRC2017

题意:刚开始地图上有一些地方已经着火,用'f'表示,初始的时候人在's'处,想要到't'处坐直升机逃跑。火势会蔓延,每过k秒大火会蔓延到周围的八个网格,人每一秒只能选择上下左右四个方向中的一个方向移动。问是否能成功逃生,如果能最短时间是多少。

思路:这道题我们可以把火看成是墙壁,和普通的bfs题不一样,这个“墙壁”会变化扩散。所以我们可以先bfs一次确定火势蔓延的状态,然后再bfs一次确定逃跑路线。第一次bfs记录下每一个网格被火势蔓延的时间time,在第二次bfs的时候只需要判断一下人走到某一个网格的时间是否小于time即可。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
const int inf=0x3f3f3f3f;
char s[105][105];
int t[105][105];
int vis[105][105];
int fx[]={1,-1,0,0,1,1,-1,-1};
int fy[]={0,0,1,-1,1,-1,1,-1};
int px[]={1,-1,0,0};
int py[]={0,0,1,-1};
int n,m,k,sx,sy;
struct node
{
    int x,y,step;
}r,p,q;
queue<node> Q;
void bfs_fire()
{
    int i,j;
    while(!Q.empty())
    {
        p=Q.front();
        Q.pop();
        for(i=0;i<8;i++)
        {
            q=p;
            q.x+=fx[i];
            q.y+=fy[i];
            q.step+=k;
            if(q.x<0||q.y<0||q.x>=n||q.y>=m)
                continue;
            if(vis[q.x][q.y]==0)
            {
                vis[q.x][q.y]=1;
                t[q.x][q.y]=q.step;
                Q.push(q);
            }
        }

    }
}
int bfs_people()
{
    while(!Q.empty())
        Q.pop();
    memset(vis,0,sizeof(vis));
    int i,j;
    p.x=sx;
    p.y=sy;
    p.step=0;
    vis[p.x][p.y]=1;
    Q.push(p);
    while(!Q.empty())
    {
        p=Q.front();
        Q.pop();
        //printf("%d %d\n",p.x,p.y);
        if(s[p.x][p.y]=='t')
            return p.step;
        for(i=0;i<4;i++)
        {
            q=p;
            q.x+=px[i];
            q.y+=py[i];
            q.step++;
            if(q.x<0||q.y<0||q.x>=n||q.y>=m)
                continue;
            if(vis[q.x][q.y]==0&&q.step<t[q.x][q.y])
            {
                vis[q.x][q.y]=1;
                Q.push(q);
            }
        }
    }
    return -1;
}

int main()
{
    int i,j;
    while(scanf("%d %d %d",&n,&m,&k)!=EOF)
    {
        if(n==0&&m==0&&k==0) break;
        memset(t,inf,sizeof(t));
        memset(vis,0,sizeof(vis));
        while(!Q.empty())
            Q.pop();
        for(i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            for(j=0;j<m;j++)
            {
                if(s[i][j]=='f')
                {
                    r.x=i;
                    r.y=j;
                    r.step=0;
                    t[i][j]=0;
                    vis[i][j]=1;
                    Q.push(r);
                }
                if(s[i][j]=='s')
                {
                    sx=i;
                    sy=j;
                }
            }
        }
        bfs_fire();
        int ans=bfs_people();
        if(ans==-1)
            printf("Impossible\n");
        else
            printf("%d\n",ans);

    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值