pat-关于堆的判断

14 篇文章 0 订阅

7-5 关于堆的判断(25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N 1000)和M 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
#include<bits/stdc++.h>
using namespace std;
class cmp{
public:
    bool operator()(int a, int b)
    {
        return a > b;
    }
};
int a[100005];
map<int,int> mp;
int f(int flag,int s,int e)
{
	if(flag==1)
	{
		if(a[1]==s)
		return 1;
		else return 0;
	}
	if(flag==2)
	{
		if(a[mp[e]/2]==s)
		return 1;
		else return 0;
	}
	if(flag==3)
	{
		if(a[mp[s]/2]==e)
		return 1;
		else return 0;
	}
	if(flag==4)
	{
	//	cout<<s<<' '<<e<<"---"<<mp[s]<<' '<<mp[e]<<endl;
		if(mp[s]/2==mp[e]/2)
		return 1;
		else return 0;
	}
}
int main()
{
  int n,m;
  cin>>n>>m;
 
  for(int i=1;i<=n;i++)
  {
    cin>>a[i];
    make_heap(a+1,a+i+1,greater<int>());
  }
 
  for(int i=1;i<=n;i++)
  {
  	mp[a[i]]=i;
  //	cout<<a[i]<<' ';
  }
  for(int i=0;i<m;i++)
  {
  	int s;
  	cin>>s;
  	   string str;
       cin>>str;
    	if(str=="is")
    	{
    		cin>>str;
    		if(str=="the")
    		{
    			cin>>str;
    			if(str=="root")
    			{
    				if(f(1,s,-1))
    				{
    					cout<<"T\n";
					}
					else cout<<"F\n";
				}
				else{
					int end;
					cin>>str>>end;
					if(f(2,s,end))
    				{
    					cout<<"T\n";
					}
					else cout<<"F\n";
				}
			}
			else {
				int end;
				cin>>str>>str;
				cin>>end;
				if(f(3,s,end))
    				{
    					cout<<"T\n";
					}
					else cout<<"F\n";
			}
		}
		else {
			int end;
			cin>>end>>str>>str;
			if(f(4,s,end))
    				{
    					cout<<"T\n";
					}
					else cout<<"F\n";
			
		}
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值