A1046 Shortest Distance [简单模拟--卡算法复杂度]

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:

3
10
7

————————————————
这个第三个测试点,考察复杂度,卡时间点,原本的复杂度太高了,达到了M*N的复杂度,采用走一步存一步的方法,这样复杂度讲到了常数1。

#include<iostream>
using namespace std;
int main()
{
	int n, m, a[100001] = { 0 }; int sum = 0;int dis[100001];
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		cin >> a[i];
        sum += a[i];
        dis[i]=sum;
	}
	cin >> m; int c, d; 
	for (int i = 0; i < m; i++)
	{
		int temp1 = 0;
		cin >> c >> d;
		if (c > d)
		{
			int temp = c;
			c = d;
			d = temp;
		}
        temp1=dis[d-1]-dis[c-1];
		int temp = sum - temp1;
		if (temp <= temp1)
			cout << temp << endl;
		else
			cout << temp1<< endl;
	}
}

这个是原本的

#include<iostream>
using namespace std;
int main()
{
	int n, m, a[11110] = { 0 }; int sum = 0;
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		cin >> a[i];
        sum += a[i];
	}
	cin >> m; int c, d; 
	for (int i = 0; i < m; i++)
	{
		int dis = 0;
		cin >> c >> d;
		if (c > d)
		{
			int temp = c;
			c = d;
			d = temp;
		}
		for (int i = c; i < d; i++)
		{
			dis += a[i];
		}
		int temp = sum - dis;
		if (temp <= dis)
			cout << temp << endl;
		else
			cout << dis << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
GCN (Graph Convolutional Network) Shortest-Path-Master 是一种基于图卷积网络的最短路径算法。最短路径问题是图论中的经典问题,对于给定的图和起始点,找到到达目标点的最短路径。 GCN Shortest-Path-Master 通过应用图卷积神经网络的思想来解决最短路径问题。传统的最短路径算法(如Dijkstra算法或贝尔曼-福特算法)在计算过程中不考虑节点的特征信息,只利用图的拓扑结构。而GCN Shortest-Path-Master 利用了节点的特征信息,将节点的邻居节点信息通过图卷积操作进行聚合,得到节点的新特征表示。 GCN Shortest-Path-Master 的核心思想是,通过图卷积层不断更新节点的特征表示,使得节点的特征表示能够包含更多关于最短路径的信息。在每次迭代中,GCN Shortest-Path-Master 将节点的特征与邻居节点的特征进行聚合,得到节点的新特征表示。在网络的最后一层,通过对所有节点进行分类任务,可以得到每个节点到达目标点的最短路径预测。 相比传统的最短路径算法,GCN Shortest-Path-Master 提供了以下优势: 1. GCN Shortest-Path-Master 能够利用节点的特征,从而更好地表达节点之间的相互作用和联系。 2. GCN Shortest-Path-Master 可以自适应地学习节点的特征表示,而无需人工定义特征。 3. GCN Shortest-Path-Master 可以处理大规模的图结构,在计算效率上具有一定优势。 总之,GCN Shortest-Path-Master 是一种基于图卷积神经网络的最短路径算法,通过利用节点的特征信息,能够更好地解决最短路径问题。它在图结构数据中的应用具有很大潜力,在社交网络分析、推荐系统和物流路径规划等领域都有广泛的应用前景。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值